読者です 読者をやめる 読者になる 読者になる

ruby-pgのinstallにハマったのでメモ

ERROR: Error installing pg:
ERROR: Failed to build gem native extension.

とか言って入ってくれません。
そもそもpostgresqlが入ってなくても出てしまうので確認してなければ入れましょう。
そしてバージョンが対応してないと

Your PostgreSQL is too old. Either install an older version of this gem or upgrade your database.

とか言われてしまいます。
基本的には対応するバージョンのpostgresqlを入れなおしましょう。
入れなおせない場合はruby-pgのバージョンをあわせればとりあえず入ります。

gem install pg -v 'X.XX.X'